Google Excel ile Etkileşimli To-Do List Yapımı

Google Excel ile Etkileşimli To-Do List Yapımı

Yoğun bir çalışma programına sahipseniz veya sıkı çalışan bir öğrenciyseniz yapacağınız çok fazla iş var demektir. Eğitim, iş hayatınızda ve günlük yaşantınızda başarılı olmak için yapılması gerekenler arasında not almanın önemi sürekli vurgulanır. Not alma alışkanlığı, yapılacakları planlamanıza fazlasıyla yardımcı olur. Notlar için ajanda kullanma alışkanlığımız teknolojinin gelişmesiyle, dijital ajandaları kullanma alışkanlığına dönüştü. Gelişen bulut sistemleri sayesinde, dijital ortamda planlamalarımızı yaparak istediğimiz her yerden ulaşabiliyoruz. Bu kolaylığı sağlayan bir çok farklı platform bulunmaktadır. Bunlardan en çok kullanılanlar arasında Google Drive de bulunmaktadır. Drive ile gelen özellikler işlerimizi kolay şekilde planlamamız ve dijital ortamda belirli kapasiteye kadar ücretsiz yararlanmamızı sağlıyor.

Google Drive hizmetleri arasında bulunan excel tablolarını kullanarak, basit ve  kullanışlı bir    To-do List( Yapılacaklar Listesi) çalışması yapacağız. Yapılacaklar listemizi, ufak bir dokunuşla etkileşimli hale getirerek, kullanım deneyimine farklılıklar katacağız.

Yapılması gereken işlerin öncesi ve sonrası şeklinde iki fonksiyon kullanacağız. İşin yapılmadan önceki hali ve tamamlandıktan sonra ki hali, yerleştireceğimiz onay kutusu sayesinde basit şekilde değişecektir.

Başlayalım…

Öncelikle Google Drive’da “Yeni” butonuna tıklayarak Google E-tablolarda boş e-tablo açıyoruz.

Google Excel ile Etkileşimli To-Do List Yapımı
TGorsel1

Çalışma dosyanıza istediğiniz ismi verebilirsiniz. Ben “Yapılacaklar Listesi” şeklinde isimlendirdim.

Google Excel ile Etkileşimli To-Do List Yapımı

Tabloda 4 sütunu kullanacağım. Bunun için A,B,C,D Sütunları dışında ki sütunları siliyorum. Bu işlemi yapmak için silinecek sütunları seçerek sütunları sil demeniz yeterli.

Google Excel ile Etkileşimli To-Do List Yapımı

Kalan ve üzerinde çalışma yapacağım 4 sütun da kılavuz çizgileri olmadan çalışmak istiyorum. Bunun için kılavuz çizgilerini kaldırıyorum. Siz kaldırmadan da çalışabilirsiniz.

Google Excel ile Etkileşimli To-Do List Yapımı

Kılavuz çizgilerini kaldırdıktan sonra kullanmak üzere aynı tip bir çalışma sayfası daha oluşturuyorum. Bunun için aşağıda bulunan sayfa isminin üzerine tıklıyor ve kopyala diyoruz. Benzer bir kopya sayfanın açıldığını göreceksiniz.

Google Excel ile Etkileşimli To-Do List Yapımı

İlk sayfada yapacaklarımız ve onay işlemleri görünecek. İkinci sayfada ise, tamamlanma öncesi ve sonrası bilgilendirme listesi bulunacak. Bu nedenle ilk sayfaya Kontrol Listesi olarak, ikici sayfayı ise Yapılacaklar Listesi olarak isimlendirdim. İsimlendirmeyi kendize göre ayarlayabilirsiniz.

Google Excel ile Etkileşimli To-Do List Yapımı

Yapılacaklar Listesi sayfasını düzenlemeyle devam ediyoruz. Bu sayfada, yapacağımız işin öncesinde ve sonrasında yazılacak olan açıklamaları ayarlayacağız. Sadece A ve B Sütunlarını bırakarak diğer Sütunları silebilirsiniz.  Sonrasında A Sütununa “Tamamlamadan Önce” B Sütununa “Tamamladıktan Sonra” şeklinde iki farlı başlık veriyoruz.

Google Excel ile Etkileşimli To-Do List Yapımı

Kontrol Listemize dönüp burada da gerekli düzenlemeleri yapıyoruz. Öncelikle listenin C Sütununda görüntülenmesini istediğim için sütunu genişletiyorum ve C2 Sütununa bir başlık yazıyorum.

Google Excel ile Etkileşimli To-Do List Yapımı

Listemizde ki görevleri tamamladıkça, tik atacağımız onay kutusunu B3 Sütununa ekliyorum. Bunun için Ekle menüsünden onay kutusuna tıklamanız yeterli.

Google Excel ile Etkileşimli To-Do List Yapımı

Şimdi  Yapılacaklar Listesine dönüp, kendimize göre belirlediğimiz işleri yazıyoruz. “Tamamlamadan önce” iş tanımının nasıl görünmesini istiyorsunuz, işi “Tamamladıktan Sonra” nasıl görünmesini istiyorsunuz? Uygun şekilde iki sütuna da yazıyoruz. Benim yazdığım örnekten yola çıkabilirsiniz.

Google Excel ile Etkileşimli To-Do List Yapımı

Sıra geldi Yapılacaklar listesini kontrol listesinde göstermeye. Bunun için C3 hücresine giderek bir kod yazmamız gerekiyor. Kodumuzda; Yapılacaklar listesinin Tamamlanmadan önce ki halini C3 sütununda gösterilmesini, işi tamamladıktan sonra onay kutusuna tıkladığımda C3 sütunun tamamlandıktan sonra ki halini göstermesini isteyeceğiz.

Google Excel ile Etkileşimli To-Do List Yapımı

Bunun için C3 Sütununa geçip bu kodu yazıyoruz ; =EĞER(B3;’Yapılacaklar Listesi’!B2;’Yapılacaklar Listesi’!A2)

Kodu yazmadan tıklayarak yapmak daha basit olacaktır. Bunun için =EĞER( Komutunu yazdıktan sonra Ctrl’yi basılı tutarak gerekli olan hücreleri seçmeniz yeterli olacaktır.

Kodu doğru yazdığımız halde, yapılacaklar listemiz hazır olacaktır. Bu ayarları tüm hücrelere uygulamak için, yapmış olduğumuz hücreyi seçip hücrenin sağ alt köşesinde bulunan kareden tutarak aşağı çekiyoruz.

Google Excel ile Etkileşimli To-Do List Yapımı

Etkileşimli görev listemizde ki görevleri tamamlayıp onayladığımızda görev açıklamalarının değiştiğini göreceksiniz.

 

Tamamlanmadan öncesi:

Google Excel ile Etkileşimli To-Do List Yapımı

Tamamlandıktan Sonrası:

Google Excel ile Etkileşimli To-Do List Yapımı

Oluşturduğumuz tablonun kopyasına ulaşabileceğiniz linki aşağıda paylaştım. Hızlı kullanım için tabloyu kendi hesabınıza kopyalamanız yeterli.

Tablo için Tıklayın

Fikrini Paylaş :

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir